Please Note: We are experiencing an issue where some shops sales are missing from various data sets. We expect this to be resolved by 3pm ET

Incident Report for Hifyre

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 14:22 EDT

Investigating

We are currently investigating this issue.
Posted Jul 08, 2025 - 13:21 EDT
This incident affected: Hifyre IQ (IQ Dashboards).