Please Note: There is a delay in loading Canadian market data beyond Apr 17th, we are currently working on a resolution.
Incident Report for Hifyre
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 17:46 EDT
Investigating
We are currently investigating this issue.
Posted Apr 22, 2024 - 16:42 EDT
This incident affected: Hifyre IQ (IQ Dashboards).