There is an issue impacting sales data in Retailer and Supplier dashboards
Incident Report for Hifyre
Resolved
This incident has been resolved.
Posted Jul 14, 2021 - 15:47 EDT
Investigating
We are currently investigating this issue.
Posted Jul 14, 2021 - 15:25 EDT
This incident affected: Hifyre IQ (IQ Dashboards).