Please Note: We are an experiencing an issue with Sales metrics being overstated, the issue began at around 10am ET, and we expect it to be resolve by 1pm ET

Incident Report for Hifyre

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 12:33 EDT

Investigating

We are currently investigating this issue.
Posted Apr 07, 2025 - 11:29 EDT
This incident affected: Hifyre IQ (IQ Dashboards).