Please Note: Sales data for May 28th is understated, we are working on a resolution and expect this to be resolved by 12pm ET

Incident Report for Hifyre

Resolved

This incident has been resolved.
Posted May 29, 2025 - 11:36 EDT

Investigating

We are currently investigating this issue.
Posted May 29, 2025 - 09:08 EDT
This incident affected: Hifyre IQ (IQ Dashboards).