Please note: We are currently performing maintenance to Hifyre IQ which may temporarily impact access to dashboards.
Incident Report for Hifyre
Resolved
This incident has been resolved.
Posted Jan 07, 2022 - 13:03 EST
Investigating
We are currently investigating this issue.
Posted Jan 07, 2022 - 12:55 EST
This incident affected: IQ Dashboards.