We are experiencing a delay loading data from Oct 9th to today, we expect this to be resolved by 5pm EST
Incident Report for Hifyre
Resolved
This incident has been resolved.
Posted Oct 11, 2022 - 16:50 EDT
Investigating
We are currently investigating this issue.
Posted Oct 11, 2022 - 08:01 EDT
This incident affected: Hifyre IQ (IQ Dashboards).