Please Note: We are currently experiencing an issue with our Canadian Retail Sales market data being understated for May 2025. We expect this to be resolved by 2:30pm ET.

Incident Report for Hifyre

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 14:07 EDT

Investigating

We are currently investigating this issue.
Posted Jun 02, 2025 - 11:14 EDT
This incident affected: Hifyre IQ (IQ Dashboards).