Please note: We are experiencing an issue with Canada Retail Sales impacting accuracy of the data. We expect this to be resolved by EOD
Incident Report for Hifyre
Resolved
This incident has been resolved.
Posted Jul 18, 2023 - 11:54 EDT
Investigating
We are currently investigating this issue.
Posted Jul 18, 2023 - 10:50 EDT
This incident affected: Hifyre IQ (IQ Dashboards).