We are an experiencing an issue where Retailer and Supplier sales data is being miscounted. Market data is not impacted.
Incident Report for Hifyre
Resolved
This incident has been resolved.
Posted May 03, 2022 - 17:34 EDT
Investigating
We are currently investigating this issue.
Posted May 03, 2022 - 17:12 EDT
This incident affected: Hifyre IQ (IQ Dashboards).