Note: We are experiencing a delay loading data beyond Sept 22nd for Retailer and Supplier dashboards.
Incident Report for Hifyre
Resolved
This incident has been resolved.
Posted Sep 25, 2021 - 11:10 EDT
Investigating
We are currently investigating this issue.
Posted Sep 23, 2021 - 16:29 EDT
This incident affected: IQ Dashboards.