Please Note: We are currently experiencing an issue with retail sales being overestimated in the province of QC and PEI for June 22nd and beyond. We are working to resolve as soon as possible.

Incident Report for Hifyre

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 16:56 EDT

Investigating

We are currently investigating this issue.
Posted Jun 27, 2025 - 16:08 EDT
This incident affected: Hifyre IQ (IQ Dashboards).